Google Login Issues

Incident Report for Disco

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 16:30 EDT

Identified

The issue has been identified and a fix is being deployed.
Posted Jul 03, 2026 - 16:11 EDT

Update

The team continues to investigate the outage.
Posted Jul 03, 2026 - 16:08 EDT

Investigating

Google Auth is currently not working for all Disco academies. The team is investigating the issue. Email, Apple and other login methods continue to operate as normal.
Posted Jul 03, 2026 - 15:31 EDT
This incident affected: Platform.